Welcome, Guest
Username: Password: Remember me
08 Oct 2017
Well, you've probably noticed by now that things look a little different around here. You are a keen observer!

The whole site is new and that includes all of the software that drives this forum. With probably over 10,000 settings and hundreds of back-end programs trying to talk to one another, there are bound to be a few glitches that we haven't discovered yet. So, if you happen to stumble upon anything that just doesn't seem right, give us a shout and we'll try to sort it out.

Thanks for using the VCOA Forum and enjoy the new look!
  • Page:
  • 1

TOPIC: Question 1999 v70 xc/AWD engine "dead"

1999 v70 xc/AWD engine "dead" 5 years 1 month ago #479

  • surpata2
  • surpata2's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
1999 v70 xc/ AWD 231300 miles:

I was driving yesterday @40-50 mph when I accelerated to 60, all of a sudden the engine started spewing white exhaust and then started sputtering and not idling when I stopped at a red light 5 minutes later. It stalled but it re started and I got it home at 25 mph. I changed the spark plugs this morning, # 3 and # 4 were filled with oil and there was oil covering the whole top of the engine block. After changing the plugs and mopping up all the oil, it didn't even come close to starting.

Got it towed to the mechanic and he said I need a new engine. Starting est. $2500. This is a 99 v70 XC/ AWD with a rebuilt transmission 75000 mi ago and with ok brakes, new tires and new battery.
The mechanic said it was running rich, and that the timing belt was off by one mark. Is it worth repairing or should I cut my losses? Ironically I just ordered the 3rd row jump seat to install to add more room and versatility with the amount of carpooling we do.

Please Log in or Create an account to join the conversation.

Re: 1999 v70 xc/AWD engine "dead" 5 years 1 month ago #482

  • gdill3
  • gdill3's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 1019
  • Karma: 11
  • Thank you received: 87

surpata2 wrote: 1999 v70 xc/ AWD 231300 miles:

I was driving yesterday @40-50 mph when I accelerated to 60, all of a sudden the engine started spewing white exhaust and then started sputtering and not idling when I stopped at a red light 5 minutes later. It stalled but it re started and I got it home at 25 mph. I changed the spark plugs this morning, # 3 and # 4 were filled with oil and there was oil covering the whole top of the engine block. After changing the plugs and mopping up all the oil, it didn't even come close to starting.

Got it towed to the mechanic and he said I need a new engine. Starting est. $2500. This is a 99 v70 XC/ AWD with a rebuilt transmission 75000 mi ago and with ok brakes, new tires and new battery.
The mechanic said it was running rich, and that the timing belt was off by one mark. Is it worth repairing or should I cut my losses? Ironically I just ordered the 3rd row jump seat to install to add more room and versatility with the amount of carpooling we do.


Welcome to the VCOA Forum, Josh.

See my reply here...

vcoa.org/forum/26-S70-V70--V70XC---%281998-2000%29/480-1999-v70-xcAWD-engine-dead

George Dill

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.445 seconds

Please publish modules in offcanvas position.