Welcome, Guest
Username: Password: Remember me
06 Oct 2013
The VCOA Forum is open for non-member participation! You do not need to be a paid VCOA member to post and respond to forum threads.
Read More...
  • Page:
  • 1

TOPIC: Question Catalytic Converter

Catalytic Converter 5 years 9 months ago #315

  • swirth1
  • swirth1's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 0
The dealership diagnosed bad oxygen sensors and catalytic converter when I took my '01 S40 in with the
'Check Engine' light on. I decided to put off the $1700 repair to research my options. On the way home,
the check engine light went off (and has been off for a week). When I checked with the dealer, he said
that didn't mean everything was okay, the parts were still bad and the check engine light would eventually come back on.
My question is- is this correct? I asked at an auto parts store if the check engine light goes off Is there still a problem and they said no. At this point, there is no problem with engine performance except a slight reduction in gas mileage. Since I already intended to sell before the issue came up, I can't just wait and see if the problem doesn't come back- I don't want to try to trade in a car and have them tell me I still have this problem.
Is there a diagnostic test that the dealer or anybody else performs to actually determine if the part is bad or are they all going to rely on the cars computer to tell them that? Also, can the check engine light be manually reset (similar to resetting the service required light which I have done) or by the check engine light going out is that a true sign that there is no problem?
Thanks for any responses.

Please Log in or Create an account to join the conversation.

Re: Catalytic Converter 5 years 9 months ago #316

  • c_long20
  • c_long20's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 43
  • Thank you received: 8
It's an old S40, check engine lights are very common and fickle. The EMS 2000 software program sometimes gives a code with no issue especially after certain repairs. Those dang lights have driven me crazy since day one in our market. There are a couple very old tech journals on that issue even a recall on some for a 02 sensor wiring. Check for latest s/w in the ecm, replace both 02 sensors, reset adaptation, ship vehicle is the normal process for me. If it comes back on I clear it and ship it 2 more times then recommend a cat.

Like I said those cars are very fickle when it comes to cel. I would let it go for a bit and if it comes back try replacing the sensors with Volvo parts NOT aftermarket. PM me and I will tel you how to reset the fuel adaptations, I don't want to run the risk of stupid people breaking crap.

Hope this helps.
The following user(s) said Thank You: swirth1

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.789 seconds