Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Setting idle on a B20F D-Jetronic FI system

Setting idle on a B20F D-Jetronic FI system 5 months 3 weeks ago #2287

  • tailfin
  • tailfin's Avatar
  • OFFLINE
  • Administrator
  • Posts: 187
  • Thank you received: 8
  • Karma: 1
I would expect wires soldered to both sides of Comb Conductors to be connected to 9 and 20, and it doesn't look that way.

Sharp eye!

I pulled the cover of the TPS and checked to verify that my graphic was correct; and it is. But if they were wired to 14 and 17 then the engine would not accelerate and probably not run at all. It seemed likely that the plug must be installed upside down, but no to that as well. It will only install one way.

Pulling the rubber cable cover back revealed the answer. On this TPS, the wires are numbered and the numbering starts with 17 at the top (on the right in the graphic) and 9 at the bottom - completely reversed. So, we're both right. Good catch! Although, in pulling the cover back I broke another of those "rather thin and brittle" wires. Dang it!

I snagged that graphic from a Porsche site somewhere and didn't catch the numbering difference. Now I need to find the graphic I edited and reverse the numbers.

the micron thick gold plating you abrade off with a pencil eraser today...

I am well aware of the damage caused to gold contacts as my first career, was in the engineering lab of an electronics firm. However, the TPS on my 1800 was never plated with gold, so I wasn't too concerned about damaging the contacts.

it is a product of excellent design and construction and quite reliable indeed

This is reassuring. I'll have to find something else to keep me awake at night.

I commend your good work and presentation above, and note that ALL hand-on experience is welcome during an investigation!

Thank you for the complement. If I can assist in some other way, please let me know. There will come a time when these rock solid ECUs do start to fail and if there is a source of quality information available, we may be able to repair them and keep them running.


Cheers to you!

Ed
I want to die like my Grandfather did, peacefully in his sleep.
Not screaming in terror like the passengers in his car.
You must register to gain posting privileges.

Setting idle on a B20F D-Jetronic FI system 5 months 3 weeks ago #2288

  • Ron Kwas
  • Ron Kwas's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Karma: 0
Ed;

"Sharp Eye" ...I'll take that as a compliment, thanks!

"...TPS ...wires...completely reversed" ...interesting...so two wrongs made a right?...I have seen that before...! I also have another first hand report that a wrongly connected TPS allowed the injection to work just fine...this probably didn't provide any enrichening pulses, but we know MAP sensor alone (with no TPS connected whatsoever!) will allow engine to run too...

"...broke another of those...wires" ...I recommend you replace brittle/broken wires with Teflon insulated wires which will stand up to under-hood temps. Use lineman's splice!

"TPS on my 1800 was never plated with gold" so it must have been an early TPS...OK so you wouldn't be abrading away gold, but you would be abrading away conductor material (bad) and oxidation (good, but only if was immediately followed by treatment with Deoxit to prevent future surface oxidation and allow a good contact of the slider).

"I'll have to find something else to keep me awake at night" I'm sure I don't have to help you with that!

"There will come a time when these rock solid ECUs do start to fail" The "bathtub reliability curve" says eventually they will, but thanks to the fact that Porsche, Opel Renault, VW, and a few other I can't think of right now used the D-Jet, there are enough users out there to make it worthwhile for someone to offer reliable ECU test and repair services...time alone will make the electrolytic capacitors start to open up eventually...

Cheers
You must register to gain posting privileges.
  • Page:
  • 1
  • 2
Time to create page: 0.139 seconds

We have 104 guests and one member online

  • Diana
You are here: Home Forum RWD Forums P1800, 1800S, 1800E/ES Setting idle on a B20F D-Jetronic FI system